# Installation Guide for

**Novalnet Shopware 6 Plugin**

<table>
<thead>
<tr>
<th>Version</th>
<th>Date</th>
<th>Remarks</th>
</tr>
</thead>
<tbody>
<tr>
<td>12.1.1</td>
<td>26.07.2021</td>
<td>[Fix] Compatibility issue with Shopware 6.4 series&lt;br&gt;[Enhanced] Callback has been optimized as per the new testcase</td>
</tr>
</tbody>
</table>

🎨 For previous version changelog, go to [https://github.com/Novalnet-AG/Shopware-6-payment-integration-novalnet/blob/master/changelog.txt](https://github.com/Novalnet-AG/Shopware-6-payment-integration-novalnet/blob/master/changelog.txt)
# TABLE OF CONTENTS

1 QUICK SETUP .................................................................................................................................................. 3

1.1 Plugin Installation ........................................................................................................................................... 3

1.1.1 Plugin Installation via Package ......................................................................................................................... 3

1.1.2 Upgrading the Novalnet Payment Plugin ......................................................................................................... 5

1.1.3 Updates (Local Update) .................................................................................................................................. 5

1.2 Global Configuration in the Shopware shop system .......................................................................................... 6

1.2.1 Notification/Webhook configuration in the Novalnet Admin Portal ................................................................. 8

1.2.2 Client key configuration in the Novalnet Admin Portal .................................................................................... 10

1.3 Payment Activation in the Novalnet Admin Portal ............................................................................................ 11

1.4 Payment Configuration in the Shopware shop system ....................................................................................... 13

1.5 Readme procedures to display the Novalnet transaction details ...................................................................... 14

2 TESTING AND GOING LIVE ............................................................................................................................. 15

3 ADDITIONAL CONFIGURATION .......................................................................................................................... 16

3.1 Additional configuration for all the payment methods ....................................................................................... 16

3.2 Additional configuration for Credit/Debit Cards .............................................................................................. 20

4 MANAGING SHOPWARE ADMIN PANEL .................................................................................................... 20

4.1 Order Management ........................................................................................................................................... 20

4.2 Transaction overview ....................................................................................................................................... 21

4.3 Order details for Instalment payments ................................................................................................................ 21

4.4 Confirming / Cancelling a transaction ................................................................................................................. 22

4.4.1 Manual Confirmation and Cancellation of a transaction using payment status .............................................. 23

4.5 Refunding an order ............................................................................................................................................. 23

4.5.1 Manual order refund using payment status ....................................................................................................... 24

4.6 Refunding Instalment orders .............................................................................................................................. 25

4.6.1 Cancelling Instalment orders ........................................................................................................................... 26

4.6.2 Manual Instalment cancellation using payment status ..................................................................................... 26

5 UNINSTALLATION .................................................................................................................................................. 27

6 TECHNICAL SUPPORT THROUGH NOVALNET ............................................................................................... 29
1 QUICK SETUP

This guide describes the quick installation procedure of Novalnet payment plugin (this guide comes along with the plugin), to integrate it with your shop system and to start accepting payments worldwide. For this integration, a Novalnet merchant account is needed to accept Novalnet payments, so please make sure that you have received your merchant account details from our sales team. If not, drop a mail to sales@novalnet.de

This Novalnet payment plugin package version (12.1.1) supports the following versions of Shopware 6:

6.3.0.0 - 6.4.2.1

To get started:

1. Log in to the Novalnet Admin Portal with your merchant account details (user credentials).
2. Log in to your Shopware 6 shop system.
3. Make sure that you have extracted the payment plugin package from the zip file you have received. If you have received only the installation guide without the payment plugin package (zip file), please send us a mail to technic@novalnet.de with your merchant ID.

1.1 Plugin Installation

1.1.1 Plugin Installation via Package

To install the Novalnet Payment Plugin, please go to your shop system and follow the steps below.

Step 1: Navigate to Extensions ➔ My extensions in your shop admin panel as shown below

Figure 1

Step 2: Click on the Upload extension and choose the NovalnetPayment.zip file that you will find included in the Novalnet Shopware plugin package.

Figure 2
Step 3: Once uploaded the NovalnetPayment.zip plugin will be shown under Apps tab as shown below

![Figure 3]

Step 4: Now click on Install app link to install the Novalnet Payments.

![Figure 4]

Then click on the slide button to activate Novalnet Payments as shown below.

![Figure 5]
1.1.2 Upgrading the Novalnet Payment Plugin

💡 You can get the updated plugin either directly from the Shopware store, or by contacting our technical team or via Novalnet homepage.

💰 Earlier version of the Novalnet Payment plugin should be installed in the shop to make the Store update.

1.1.3 Updates (Local Update)

Update the Novalnet Payment plugin in your shop backend to the current version without changing the previous plugin configurations.

💰 A Shopware account is not required to update the Novalnet Payment plugin in your shop system.

Step 1: Navigate to Extensions → My extensions and click Upload extension as shown in Figure 1 and 2.

Step 2: Click icon under Novalnet Payments and then click Update to version number.

Figure 6

💰 After updated the latest plugin you must uninstall and proceed with the install process.
Next, the updated version of Novalnet Payment plugin will be displayed in your shop backend (as shown in the image below).

![Figure 7]

### 1.2 Global Configuration in the Shopware shop system

The main configuration occurs in your Shopware 6 shop system as well as in the [Novalnet Admin Portal](mailto:).

In your Shopware 6 shop admin panel navigate to **Extensions → My extensions → Extensions** as shown below.

![Figure 8]
Next, you will be forwarded to the Global Configuration page as shown below to enter the following keys:

- **Product activation key** - a unique token for merchant authentication and payment processing.
- **Payment access key** - a secret key assigned to each merchant which encrypts the data to avoid user manipulation and fraud.
- **Tariff ID** - a unique identifier created based on the tariff type at Novalnet.

To get your **Product activation key** and **Payment access key**, go to the [Novalnet Admin Portal](https://example.com), navigate to the **PROJECT** menu and choose your project as shown below.

![Configuration Page](image)

**Figure 9**

**Figure 10**
Click **Shop Parameters** and copy **API Signature (Product activation key)** and **Payment access key** as shown below.

![Figure 1](image1)

Paste the **Product activation key** and **Payment access key** in the respective fields in your shop admin panel. Next, choose the Tariff ID from the drop down menu that you have created in the [Novalnet Admin Portal](https://shopware.novalnet.de) for this Shopware shop system.

![Figure 12](image2)

Then click **Save settings** to update the changes.

### 1.2.1 Notification/Webhook configuration in the Novalnet Admin Portal

In the **Global Configuration** page, on your shop admin panel, you will find your **Notification / Webhook URL Setup** under **Merchant script management** as shown below.

![Figure 13](image3)
Click **Configure** to set up your **Notification / Webhook URL** in the **Novalnet Admin Portal** as shown below.

![Configure](https://shopware.novalnet.de/novalnet/callback)

**Figure 14**

After successful configuration, your shop **Webhook URL** will be linked with your Novalnet Merchant account which can be seen under **Vendor script URL/ Notification & Webhook URL** field of your project as shown below.

![Vendor script URL/ Notification & Webhook URL](https://shopware.novalnet.de/novalnet/callback)

**Figure 15**

In your shop system, you can additionally test the Webhook URL manually and send notification emails to specific email addresses as shown below.

![Notification / Webhook URL Setup](https://shopware.novalnet.de/novalnet/callback)

**Figure 16**

1. **Notification / Webhook URL Setup** - Required to keep the merchant’s database/system up to date and synchronized with Novalnet (for example: up-to-date transaction status delivery).
2. **Allow manual testing of the Notification / Webhook URL** - Enable this to test the Novalnet Notification / Webhook URL manually. Disable this before setting your shop system live, to block unauthorized calls from external parties.
3. **Send e-mail to** - Every execution will be sent as a message to the e-mail address defined in this field.
1.2.2 Client key configuration in the Novalnet Admin Portal

The client key is a unique key which is linked with your Novalnet merchant account to authenticate your client based requests. You need the client key to render the secure payment form and tokenize (temporarily) the sensitive information.

- Novalnet allows client-side request(s) only from the whitelisted domains under a particular project in the Novalnet Admin Portal. The domain must be a valid (secured https://) website. Please follow the below steps to whitelist the domains in the Novalnet Admin Portal. You can configure multiple domain URLs under a single client key.

Step 1: Go to the Novalnet Admin Portal.

Step 2: Navigate to the PROJECT menu and click view icon on the right to view your project details as shown below.

Step 3: On the project details page click Shop Parameters and click ❌ Edit beside Allowed Domain(s) as shown below.

Step 4: Paste your website URL in the Domain name field and click + Add as shown below.
Step 5: After adding the Domain name, the web URLs are listed under Allowed Domain(s) as shown below.

**Figure 20**

1.3 Payment Activation in the Novalnet Admin Portal

All the Novalnet supported payment methods can be viewed here: [www.novalnet.com/payment](http://www.novalnet.com/payment) if you have questions about the payment methods or for additional payment method requests, please contact sales@novalnet.de

To activate the preferred payment methods for your website, navigate to Novalnet Admin Portal → PROJECT → choose your project → Payment Methods → click Edit Payment Methods in the top right corner as shown below.

**Figure 21**
Now select the preferred payment methods and click **Update** to activate them as shown below.

![Figure 22](image-url)

To use the **PayPal** payment method, configure the PayPal API details in the **Novalnet Admin Portal** as shown below.

![Figure 23](image-url)

To use the **PostFinance** payments, configure **Ep2-Merchant ID** details in the **Novalnet Admin Portal** as shown below.

![Figure 24](image-url)
1.4 Payment Configuration in the Shopware shop system

After activating the payment methods in the Novalnet Admin Portal, you must enable these payment methods in your shop admin panel to display them on your Shopware 6 checkout page. Navigate to **Settings → Shop → Payment** as shown below.

**Figure 25**

Select a particular payment method and click **Edit** to activate the payment method as shown below.

**Figure 26**
Click **Active** to activate the payment method and click **Save** to update/save the changes made as shown below.

![Direct Debit SEPA interface](image)

**Figure 27**

Refer chapter **3 ADDITIONAL CONFIGURATION** for more payment configurations.

- If you have any recommendations or suggestions for improvement kindly share your thoughts with us to develop our payment plugins further [technic@novalnet.de](mailto:technic@novalnet.de) or call us at +49 89 9230683-19.
- Are you happy with our service and support? Please spend a few minutes to share your success [here](mailto:technic@novalnet.de) or call us at +49 89 9230683-19.

**1.5 Readme procedures to display the Novalnet transaction details**

To display the Novalnet transaction comments with proper alignment in shop order mail, follow the below steps,

**Step 1**: Navigate to **Settings → Email templates → Type** → choose the relevant status and click **Edit** to view the **HTML** section under **Mail text**.

![Email templates interface](image)

**Figure 28**
Step 2: Add the code in the HTML block and click Save to update/save the changes as shown below.

Add the following code based on your wish in HTML block

```html
{% for transaction in order.transactions.elements %}
  <strong>Comments:</strong><br />
  {{ transaction.customFields['novalnet_comments'].replace({"/\r/\n": "<br/>"}) | raw }}
{% endfor %}
```

2 TESTING AND GOING LIVE

Execute test transactions by navigating to Settings → Plugins → Novalnet → Payment Configuration → choose the specific payment method (e.g. Credit/Debit Cards) → click Enable test mode at each payment configuration page. In the test mode the transaction amount will not be charged by Novalnet.

Refer below URL for the Novalnet test payment data for testing

https://developer.novalnet.de/testing/

Execute orders in LIVE MODE

To proceed with LIVE orders, don’t forget to uncheck/disable the Enable test mode option in the individual payment configuration page.

If you have any recommendations or suggestions for improvement, kindly share your thoughts with us to develop our payment plugins further to technic@novalnet.de or call us at +49 89 9230683-19.

Are you happy with our service and support? Please spend a few minutes to share your success here.
3 ADDITIONAL CONFIGURATION

3.1 Additional configuration for all the payment methods

For additional payment configuration settings for each payment method, navigate to Settings → Plugins → Novalnet → Payment Configuration and configure the required additional payment settings.

Enable test mode

Click Enable test mode to test payments at your checkout page as shown below. In the test mode, the transaction amount will not be charged by Novalnet.

![Enable test mode](image1)

Figure 31

Notification for the buyer

Text entered in this field will be displayed on the checkout page under the Payment description. The message can be for example: Thank you for shopping with us.

![Notification for the buyer](image2)

Figure 32

Refer to the below image to view how the notification appears to the buyer.

![Notification for the buyer](image3)

Figure 33
Payment Action (Debit immediately / Reserve funds for later)

- This option is available only Credit/Debit Cards, Direct Debit SEPA, Direct Debit SEPA with payment guarantee, Instalment by Direct Debit SEPA, Invoice, Invoice with payment guarantee, Instalment by Invoice and PayPal.

You can choose between two options – Capture and Authorize which are both explained below.

1. **Capture** - This is the default setting where transactions are directly confirmed, and funds are automatically transferred from buyer’s account to the merchant account. This can be changed as per your business requirement.

2. **Authorize** - Payment details are verified while the funds are reserved, which will be captured later. Please note for card payments, if you fail to execute a capture within 14 days the reservation on the card will automatically expire!

3. **Minimum transaction amount for authorization** - Transactions above this amount will be “authorized” only and captured later. Leave the field blank to authorize all transactions.

Payment due date (in days)

Payment due date (in days) refers to the duration (number of days) given for buyer to complete the payment. The payment process and duration may differ for each payment method.

- This option is available only for Direct Debit SEPA, Direct Debit SEPA with payment guarantee, Instalment by Direct Debit SEPA, Invoice, Prepayment and Barzahlen/viacash.

For Direct Debit SEPA, Direct Debit SEPA with payment guarantee & Instalment by Direct Debit SEPA, enter the number of days after which the payment is debited (must be between 2 and 14 days)

For Invoice, enter the number of days given to the buyer to transfer the amount to Novalnet (must be greater than 7 days). If this field is left blank, 14 days will be set by default.

For Prepayment, enter the number of days given to the buyer to transfer the amount to Novalnet (must be inbetween 7 to 28 days). If this field is left blank, 14 days will be set by default.

For Barzahlen/viacash, enter the number of days given to the buyer to pay at a store nearby. If this field is left blank, 14 days will be set by default for slip expiry.
Payment guarantee configuration
When the basic requirements (shown in the image below) are met, Novalnet offers you the option to process payments as guarantee payments. For more information about Novalnet’s guarantee payments, Please visit: https://developer.novalnet.de/onlinepayments/aboutguarantee

This option is available only for Direct Debit SEPA with payment guarantee, Instalment by Direct Debit SEPA, Invoice with payment guarantee & Instalment by Invoice.

Basic requirements:
- Allowed B2C countries: Germany, Austria, Switzerland
- Allowed B2B countries: European Union
- Allowed currency: €
- Minimum order amount: €9,99 or more
- Age limit: 18 years or more
- The billing address must be the same as the shipping address

Figure 37

Force Non-Guarantee payment
This option is available only for Direct Debit SEPA with payment guarantee and Invoice with payment guarantee.
Enable this option to process payments as non-guarantee payments when the guarantee conditions are not met.

Figure 38

Allow B2B Customers
This option is available only for Direct Debit SEPA with payment guarantee, Invoice with payment guarantee, Instalment by Direct Debit SEPA and Instalment by Invoice.
Enabling this option will allow B2B buyers to complete payments in your shop system.

Figure 39

Display Instalment Plan on Product Detail Page
This option is available only for Instalment by Direct Debit SEPA and Instalment by Invoice.
Enable this option to display the Instalment Plan in your product detail page.

Figure 40
**Instalment cycles**

Instalment cycle refers to the pre-defined period for partial payments that allow the buyers to pay their full order amount in parts. The intervals or cycles vary based on shop admin configuration.

*This option is available only for Instalment by Direct Debit SEPA and Instalment by Invoice.*

By default, installment cycle offers in your shop like (2 cycle, 3 cycle, 4 cycle, 5 cycle, 6 cycle, 7 cycle, 8 cycle, 9 cycle, 10 cycle, 11 cycle, 12 cycle)

![Figure 41](image)

The default instalment cycle details will be visible for the buyer under the chosen instalment plan, as shown below.

![Figure 42](image)
3.2 Additional configuration for Credit/Debit Cards

Enforce 3D secure on payment outside EU

By enabling this option, all payments from cards issued outside EU will be authenticated via 3DS 2.0 SCA.

CSS settings for iframe form

If you wish to change the default design of the Credit/Debit Cards form (for example to use your corporate identity), you can do it here. Leave this field unchanged to use the default settings.

4 MANAGING SHOPWARE ADMIN PANEL

4.1 Order Management

Manage your orders and view their details under Orders → Overview in your Shopware admin panel as shown below
4.2 Transaction overview

Click the order number as shown below

![Transaction overview table]

You will have a detailed overview of the Novalnet transaction details as shown below

![Transaction details]

4.3 Order details for Instalment payments

To review the completed and pending payments for a particular instalment order, click on the order number and scroll down to the Instalment Summary section as shown below

![Instalment summary]
4.4 Confirming / Cancelling a transaction

Depending on your “Payment Action” configuration, the Payment status might be automatically set to “Open” if authorization is required for an order.

To confirm or cancel the transaction of an “Open” order, navigate to Orders → Overview in your shop admin panel and select the particular order.

To confirm an “Open” order, click Confirm on the order detail page as shown below

![Figure 49](image)

Then, click Confirm in the Manage Transaction popup as shown below. After manual confirmation, Novalnet will process the transaction.

![Figure 50](image)

To cancel an “Open” order, click Cancel on the order detail page as shown below

![Figure 51](image)

Then, click Cancel in the Manage Transaction popup as shown below. After you have cancelled the order, Novalnet will cancel the transaction.

![Figure 52](image)
After you have confirmed or cancelled, the new transaction details will be displayed under Comments as shown below. Refer to the chapter 4.2 Transaction Overview for more details about the Comments.

4.4.1 Manual Confirmation and Cancellation of a transaction using payment status

To **confirm** the “Open” order, change the Payment status manually to "Paid" as shown below, and click **Update status**. After manual confirmation, Novalnet will process the transaction.

To **cancel** the “Open” order, change the Payment status manually to "Cancelled" as shown in the image below, and click **Update status**. After you have cancelled the order, Novalnet will cancel the transaction.

After you have confirmed or cancelled an order, the new transaction status will be shown under the Comments section as shown below. Refer to the chapter 4.2 Transaction Overview for more details about the Comments.

4.5 Refunding an order

You can refund the buyer either the full or partial order amount. Refund can be initiated by navigating to Orders ➔ Overview, selecting the particular order and clicking **Refund** as shown below.
Please follow the steps below to issue a refund.

**Step 1:** Enter the **Refund amount**.

**Step 2:** Note down the **Refund reference** for your future reference (only for existing transactions).

**Step 3:** Click **Refund** to refund the amount to the buyer.

![Refund screenshot](image1)

**Figure 59**

Once the full or partial order amount has been refunded, the order status will be changed. At this point, a new transaction (TID) will be generated. You will see the new transaction status under **Comments** section of the order. Refer to the chapter 4.2 **Transaction Overview** for more details about the Comments.

**4.5.1 Manual order refund using payment status**

You can refund the full order amount to the buyer. Refund can be initiated by navigating to **Orders → Overview** in your shop admin panel and select the order.

To refund the **Paid** order, change the Payment status manually to **Refunded** as shown below, and click **Update status**. After manual Refunding, Novalnet will process the transaction.

![Order status screenshot](image2)

**Figure 60**

![Order status screenshot](image3)

**Figure 61**

At this point, a new transaction (TID) will be generated. You will see the new transaction status under **Comments** section of the order. Refer to the chapter 4.2 **Transaction Overview** for more details about the Comments.
4.6 Refunding Instalment orders

To refund an instalment order, navigate to Orders → Overview and click the order. Scroll down to the Instalment Summary section and select the icon & click Refund next to the Paid instalment cycle that should be refund.

![Figure 62]

In the refund pop up that appears, enter the Refund amount and click Refund as shown below

![Figure 63]

Once the instalment order amount has been refunded, you will see the new transaction status under Comments section of the order. Refer to the chapter 4.2 Transaction Overview for more details about the Comments.
4.6.1 Cancelling Instalment orders

To cancel the instalment orders, navigate to Orders → Overview in your shop admin panel and select the order. Then, click the Instalment Cancel as shown below. After you have cancelled the instalment order, Novalnet will Cancel and refund the transaction.

![Figure 64](image)

Further there will be no recurring instalments for that order.

Once the instalment order has been successfully cancelled, you will see the new transaction status under Comments section of the order. Refer to the chapter 4.2 Transaction Overview for more details about the Comments.

4.6.2 Manual Instalment cancellation using payment status

To cancel the instalment orders, navigate to Orders → Overview in your shop admin panel and select the order. Then, change the payment status manually to "Cancelled" as shown below, and click Update status. After you have cancelled the instalment order, Novalnet will Cancel and refund the transaction.

![Figure 65](image)

![Figure 66](image)
Further there will be no recurring instalments for that order.

Once the instalment order has been successfully cancelled, you will see the new transaction status under Comments section of the order. Refer to the chapter 4.2 Transaction Overview for more details about the Comments.

5 UNINSTALLATION

To uninstall the Novalnet Payment Plugin, please follow the steps below.

Step 1: Navigate to Extensions → My extensions as shown below

Step 2: Then click ⊗ Activated switch to deactivate Novalnet Payments as shown below

Step 3: To uninstall the Novalnet payment plugin, click Uninstall as shown below

Step 4: Click ⊗ switch to remove all plugin data permanently and click Uninstall as shown below
Step 6: To delete the Novalnet payment plugin, click **Remove** as shown below

![My extensions](image1)

Figure 71

Step 7: In Pop up notification, click **Remove** as shown below

![Novalnet Payments remove](image2)

Figure 72
6 TECHNICAL SUPPORT THROUGH NOVALNET

For any questions or further enquiries please contact one of the following departments as per your requirement. Our in-house experts are ready to assist you in case of queries or issues.

For installation assistance contact technic@novalnet.de or call +49 89 9230683-19.

For a merchant account, new payment plugin or additional payment methods, please contact sales@novalnet.de or call +49 89 9230683-20.

If you have any recommendations or suggestions for improvement kindly share your thoughts with us to develop our payment plugins further technic@novalnet.de or call us at +49 89 9230683-19.

Are you happy with our service and support? Please spend a few minutes to share your success here.

For our License details see for Freeware License Agreement.